“Fun” with HP’s MFP

Tried to setup Fax-to-Mail on our shiny new HP LaserJet 200 colorMFP M276n. Turned out to be more difficult that expected :-(

Sep  9 16:01:41 mail sm-mta[15887]: STARTTLS=server, relay=hp-laser.uu.org [192.168.5.221], version=TLSv1/SSLv3, verify=NOT, cipher=AES256-SHA, bits=256/256
Sep  9 16:01:42 mail sm-mta[15887]: r89E1fbQ015887: hp-laser.uu.org [192.168.5.221] did not issue MAIL/EXPN/VRFY/ETRN during connection to MTA-v4

Seems like HP is, in 2013, still not playing SMTP by the book? The error message points to the used GreetPause feauture, but trying with another box on the LAN proved otherwise; GreetPause is not the issue. I verified username and password, that shouldn’t be the issue either. The log on the mail server suggests that after the HP starts the TLS transaction, the connection is dropped — after disabling TLS on the mail server for debugging purposes, it turned out that after the HP selects AUTH-CRAMD5 and some further exchange, the mail server rejects the credentials with “535 5.7.0 authentication”. Hrmpft. saslauthd seems to be running properly … Right now I’m too lazy to dig deeper into this, as I was able to use said other box on the LAN as a relay system for the HP MFP.