Gut, ich bin ja auch selbst schuld, irgendwie …
Ich wollte »mal eben schnell« einen FSC Futro S550 als lokales Gluon-Gateway konfigurieren und testen. Und weil Ubuntu 14.04 LTS irgendwie keine Platte fand (der Futro hat eine CF-Karte als »Platte«, die über ein wohl aus der Mode gekommenes Modul, pata_atiixp, angesprochen wird), habe ich halt das aktuelle Debian für die Installation via PXE-Boot installiert.
Nachdem aber leider auch Debian auf den systemd-Hype aufgesprungen ist, stehe ich nun mit einer geilen Fehlermeldung da und komme nicht weiter, denn das große G wirft diesbezüglich nichts passendes raus :(
root@gw-futro01:~# /usr/sbin/service iptables-persistent start Failed to start iptables-persistent.service: Unit iptables-persistent.service failed to load: No such file or directory. root@gw-futro01:~# cat /etc/debian_version 8.2
Ich vermute mal, daß die Datei iptables-persistent.service (in /lib/systemd/system/) fehlt. Warum, wieso, weshalb: keine Ahnung. Wenn kommerzielle Software nicht von Zeit zu Zeit genauso eine Scheiße produzieren würde, würde ich mich jetzt über Hipster-Coder aufregen. Statt dessen blogge ich die Fakten und gehe – etwas frustriert – schlafen ;)
[Update:] Ein beherztes
root@gw-futro01:~# ln -s /lib/systemd/system/netfilter-persistent.service /lib/systemd/system/iptables-persistent.service
nach Lektüre eines Github-Issues löste das Start-Problem. Augenscheinlich muß man ab Jessie netfilter-persistent statt iptables-persistent nutzen — wieder ein paar Namen mehr auf der Pizzaschachtel …
Damit auch »systemctl enable« klappt, versuchte ich …
root@gw-futro01:~# ln -s /etc/init.d/netfilter-persistent /etc/init.d/iptables-persistent root@gw-futro01:~# /bin/systemctl enable iptables-persistent Synchronizing state for iptables-persistent.service with sysvinit using update-rc.d... Executing /usr/sbin/update-rc.d iptables-persistent defaults insserv: script iptables-persistent: service netfilter-persistent already provided! insserv: exiting now! update-rc.d: error: insserv rejected the script header *** Error in `/bin/systemctl': double free or corruption (fasttop): 0x00007f56a3ae59c0 *** Aborted
… was, wie man sieht, nur bedingt funktionierte.
Ich werde den Jessie-Müll jetzt durch gut abgehangenes Wheezy ersetzen oder das Problem bei Trusty fixen. Für so eine Kinderkacke habe ich echt weder Zeit noch Lust.
